Font-Probleme verzögern Spielstart

Welcome to the OMSI-WebDisk!
You might have certainly noticed that the most content of user postings is written in german. But you are not forced to translate your text in german (the translations are usually not understandable anyway; but if you have learned it and want to practice, of course feel free to try it). You can write your text in english language and you will see that the community will anwser in english, too. Take it easy, our community is flexible.
  • Hallo,


    ich bekomme seit gestern beim laden einer beliebigen Karte immer die folgenden drei Errors. Das Problem tritt immer genau nach drücken des 'Start!'-Knopfes auf.

    Code: Logfile
    1. 89 19:01:19 - - Error: The file "Fonts\ANX_M_SD - ?????.oft" could not be loaded!
    2. 90 19:01:19 - - Error: The file "Fonts\ANX_S - ?????.oft" could not be loaded!
    3. 91 19:01:20 - - Error: In "Fonts\Buse_15x6.oft" there was an error in line 85!

    Wenn ich nach diesen Dateien suche finde ich folgende Dateien:


    Erst gute 5-10 Minuten später lässt sich ein Startpunkt auswählen und eine Karte laden.


    Meine Frage wäre nun: Gibt es einen Weg das Problem zu lösen?

    Files

    • logfile.txt

      (13.59 kB, downloaded 8 times, last: )
  • Das Problem sind die russ. Buchstaben. Das Problem kann du lösen:

    1. Ändere den Dateinamen. Denke dir dazu einen Namensanhang aus

    2. Ändere den Dateinamen auch innerhalb der OFT-Datei, genauso wie den Dateinamen

    3. Suche in den Busordnern, welche Busse diese Schrift verwenden:

    • Schaue in die model.cfg und trage dort die gleichen Dateinamen ein
    • Schaue, falls notwendig auch in die Matrixscripte und berichtige die dortigen Eintragungen.

    Tabsi Gruß von Tabsi und

    Tatra Bahn

    -Co-Projektleiter der WebDisk-

  • Also ich habe den Dateinamen geändert und mal im 'Vehicles'-Ordner mit Notepad++ komplett durchsuchen lassen.

    Es befindet sich in keiner Datei ein Eintrag zu den Dateien.


    Jetzt sind die Errors nicht mehr in der Logfile, dennoch bleibt die lange Ladezeit. :/

    Code: Logfile
    1. 2 21:10:36 - - Information: TIR - DLL path not found - TIR disabled [0]
    2. 3 21:14:07 - - Information: Options dialog created
    Code: Logfile
    1. 78 21:14:45 - - Information: Date: 1994 1003, Time: 152141
    2. 79 21:21:08 - - Information: Fonts initialized


    Sind diese langen Ladezeiten den normal?


  • Also laut Logfile hast du die Fehler im Font beseitigt.

    Lange Ladzeiten weisen auf andere Probleme hin. Mit unter kann es bis zu 5 Minuten dauern, wenn du viele Maps, Busse und Content installiert hast. Mit Hilfe des Programmes: StartOMSI kannst du unbenötigten Content ausblenden, so das Omsi diese Dateien nicht mitlädt. Versuche es mal.

    Leider hat Skinner_11 das Programm nicht in der WebDisk hochgeladen und angeboten. Kommt vielleicht noch.

    Tabsi Gruß von Tabsi und

    Tatra Bahn

    -Co-Projektleiter der WebDisk-