Atron AFR 4 (C2 Berlin) startet nicht (Selbsteinbau O407)

Welcome to the OMSI-WebDisk!
As guest you can only see content in your selected language! Registered users can choose the visibility of other languages in their control panel, more informations here. All topics are marked with a language flag inside the forums: = English [EN], = German [DE], = French [FR].
If you're not able to speak the topic language than write in English!
  • Hallo zusammen!

    Ich hab mir den Atron AFR 4 aus dem BRT C2 in den O407 eingebaut.

    Als ich den Bus gestartet habe, bootet der nicht und es bleibt schwarz. (sehe Bild)

    Im Logfile (ab Zeile 219) steht "Fehler: im Befehl[...]ist der Macroname ungültig!" und "ist der Variablenname ungültig!"

    Die Scripts hab ich alles eingefügt.

    Danke im Voraus!

    ps. Ich weiss, dass ich die Position per Daueranimation ändern kann :)

    Files

    • logfile.txt

      (29.52 kB, downloaded 41 times, last: )

    Avatar: BVB Cornichon 486

    Wer Rechtschreibfehler findet, darf sie gerne behalten.

  • Advertisement
  • (L.L.C2_Elektronik)


    muss


    (L.L.elec_busbar_main) heißen


    Unter {macro:AFR4_frame}



    Dann ganz unten in der AFR4.osc


    Innenanzeige_update und C2_Elektronik_Laufzeit in der varlist nachtragen


    Dann gibt es noch das Problem mit den Scripttexturen


    Dann muss folgendes angepasst werden:


    Und dann noch Änderungen in der

    Dort muss bei


    Code
    [matl_transmap]
    \S:

    auch die Zahl der Scripttexture angepasst werden


    Warum sich die Zahlen geändert haben, siehst du ja in den Scripttetxuren Da wird dann aus 4 z.B. die 2 weil die Scripttetxure im BRT C2 ne 4 war und bei mir eine 2 usw.

    #NICHTSELBSTVERSTÄNDLICH

    Edited 14 times, last by Matthias_M ().

  • CitarofanCH Hat es denn was gebracht oder brauchst du noch Hilfe? Finde es immer schade, wenn es keine Rückmeldung gibt, wenn schon Hilfestellung gegeben wurde...


    Gruß

    #NICHTSELBSTVERSTÄNDLICH

  • Matthias_M

    Hi,

    Ich habs noch nicht versucht da ich die ganze Woche am arbeiten bin/war.

    Ich werde es morgen versuchen und gebe dir dann Bescheid.


    Gruss

    Avatar: BVB Cornichon 486

    Wer Rechtschreibfehler findet, darf sie gerne behalten.

  • Hallo,


    Ich hab die fehlende OSC, varlist und model.cfg Einträge hinzugefügt und jetzt bekomme ich eine Zugriffsverletzung.

    Files

    • logfile.txt

      (681.77 kB, downloaded 26 times, last: )

    Avatar: BVB Cornichon 486

    Wer Rechtschreibfehler findet, darf sie gerne behalten.

  • C2_Elektronik muss du noch in eine Varlist eintragen.

    Nein.... Das bringt nichts. Dann geht das Atron nicht an!!!!


    Ich hatte geschrieben das aus (L.L.C2_Elektronik) muss (L.L.elec_busbar_main) gemacht werden. Einfach suchen und ersetzen


    Aus (L.L.C2_Bremse_Haltestellenbremse) muss (L.L.bremse_halte) gemacht werden.


    door_5 muss in einer varlist nachgetragen werden

    #NICHTSELBSTVERSTÄNDLICH

    Edited once, last by Matthias_M ().

  • Arrrgg!!!

    Ich versteh das einfach nicht! :ponder:

    Ich hatte geschrieben das aus (L.L.C2_Elektronik) muss (L.L.elec_busbar_main) gemacht werden. Einfach suchen und ersetzen


    Aus (L.L.C2_Bremse_Haltestellenbremse) muss (L.L.bremse_halte) gemacht werden.


    door_5 muss in einer varlist nachgetragen werden

    Ich hab das alles nachgetragen und jetzt spawnt der Bus nicht. (Edit: Dafür bekam ich keine Zugriffsverletzung)

    Ich bin einfach nicht dafür geschaffen für Bus Modding...

    Files

    • logfile.txt

      (28.96 kB, downloaded 32 times, last: )

    Avatar: BVB Cornichon 486

    Wer Rechtschreibfehler findet, darf sie gerne behalten.

  • elec_busbar_main_Laufzeit


    Muss genauso in einer varlist nachgetragen werden


    Dann hast du bei einem Scripteintrag evtl. auch bei mehreren nun in der AFR4.osc ((L.L.elec_busbar_main) also mit (( stehen. Deshalb lässt sich der Bus nicht setzen. Das bitte korrigieren Also eine ( weg wo es zweie sind

    #NICHTSELBSTVERSTÄNDLICH

  • Wenn du drunter schreibst ist es kein Problem. Daneben ohne Leerzeichen würde zum Bereichsprüfungsfehler führen

    #NICHTSELBSTVERSTÄNDLICH