Selbstgebautes Haus zeigt nicht alle Texturen an!

Welcome to the OMSI-WebDisk!
As guest you can only see content in your selected language! Registered users can choose the visibility of other languages in their control panel, more informations here. All topics are marked with a language flag inside the forums: = English [EN], = German [DE], = French [FR].
If you're not able to speak the topic language than write in English!
  • Heute wollte ich mal das erste mal ein OBJEKT für OMSI machen. Es hat fast alles funktioniert, aber nicht alles. Es sind ein Paar Verschiebungen der Blöcke von Blender in OMSI gekommen. Dazu fehlt noch eine Textur (Textur wird nicht angezeigt, nur weiß Wendern). Und ich habe schon alles versucht das zu beheben, bin gescheitert.


    Hier ist mein Logfile:

    Hier das Textur Problem und die Verschiebung in OMSI 2:



    Und hier wie es in Blender aussieht:

    Könnte mir da bitte jemand eventuel helfen?

  • Advertisement
  • Kannst du vielleicht deinen Weg grob beschreiben, wie du das Objekt gebaut und insbesondere texturiert hast?

  • Hm, merkwürdig. Hast du den Exporteinstellungen im Wiki befolgt?

    Wenn ja, dann schicke Mal den unteren Teil deiner .x-Datei hier rein, indem zu sie mit dem Windows-Texteditor öffnest. :)

    Mit unterem Teil meine ich den Teil, wo es mit den Texturen los geht. Da es sich normalerweise bei einem Haus nicht um so viele Texturen handelt, reicht wohl auch einfach ein Screenshot des Teils. :)

  • Also ich habe mein Haus mit vielen Cubes gebaut, dann habe ich in der Früh den ersten Fehler gemacht und zwa habe ich es mit Textur gemacht und nicht mit Materialien. Aber dann habe ich es auch mit Materialien gemacht und da kamen die ersten Texturen schon dabei mit den Fehlern.


    Das ist mein Pfad: C:\Program Files (x86)\Steam\steamapps\common\OMSI 2\Sceneryobjects\FBSS{Wien

    Das meine SCO Datei:

    Und diese Textur wird nicht angezeigt:

  • Ja ich habe alle Themen in Wiki befolgt


    Jap ist dort abgespeichert


    Also einige sind in dds und einige in png Format abgespeichert

    Edited 2 times, last by OMSI2Bauer: Ein Beitrag von OMSI2Bauer mit diesem Beitrag zusammengefügt. ().

  • Komisch... :/


    Schicke bitte Mal ein Bild in Blender von der Z-Ansicht, die Wireframe-Ansicht. Lässt sich halt mit Z öffnen. ;)

  • Vielleicht liegt es ja daran, dass du sehr viele Objekte in einer .o3d hast. Wähle einmal alle Objekte und zuletzt das unterste aus, und drücke anschließend STRG + J. Damit fügt du die Objekte zusammen.


    Dann exportiere das Objekt noch einmal zu der Datei, konvertiere es, und starte OMSI neu. :)


    Schicke mir auch nochmal ein Foto, genau so wie oben, bloß im Edit Mode und nur vom Dach. :)

  • Das habe ich ja schon längst gemacht;).


    Weil ich in der Früh das mit so vielen Blöcken nicht zamgehaut.

    Edited once, last by OMSI2Bauer: Ein Beitrag von OMSI2Bauer mit diesem Beitrag zusammengefügt. ().

  • Das ist die Ansicht von oben


    Sorry schreib Fehler ich habe das in der Früh mit den Blöcken gemacht und da hat es nicht mal das Haus angezeigt

    Edited once, last by OMSI2Bauer: Ein Beitrag von OMSI2Bauer mit diesem Beitrag zusammengefügt. ().

  • Ich glaube, ich weiß, woran der "Fehler" liegt.


    Du siehst ja an der Seite des Hauses ganz viele Faces, die wohl alle auf der gleichen Höhe liegen. Deshalb entsteht wohl diese unschöne Seite:

    36057-20201004155922-1-jpg


    Versuche am besten Mal, dort die Faces zu reduzieren, bspw. durch einen Polygonarmen Neubau des Daches. :)

  • Moin,

    ich habe jetzt eine ganz andere Vermutung - einfacher als gedacht. :-)


    Öffne einmal das N-Menü an der Seite (wird mit N geöffnet). Dort siehst du etwas weiter unten den Abschnitt "Shades" ...


    ... und Backface Culling. In meinem Fall ist es nun schon aktiviert. Bei dir sieht es auf den Editor-Bildern nämlich so aus, als wenn dort ein paar Polygone umgedreht sind.

    Polygone haben immer 2 Seiten. Eben eine "richtige" und eine "falsche". Wenn man in Blender nicht diese Option "Backface Culling" aktiv hat, kann man nur sehr schlecht erkennen, in welcher Richtung das Polygon zeigt. Wenn das Polygon auf die falsche Seite gedreht ist, dann ist diesesPolygon im Spiel nicht sichtbar bzw. nur sichtbar, wenn man in dem Modell steht, was aber ja eher ein Ausnahmefall ist. lol


    Als du Backface Culling aktiviert hast, sieht es jetzt so wie auch im OMSI-Editor aus. Nun gibt es 2 Wege, das zu beheben. Alle Wege finden im Edit-Mode statt.

    1. Du wählst alles an (einmal A drücken, ggf. ein zweites mal) und drückst STRG+N. Das ist eine Funktion, die die Polygone auf die für uns richtige Seite dreht. In den meisten Fällen sollte diese Möglichkeit funktionieren.
    2. Wenn du immer noch falsch herum gedrehte Polygone siehst, gehe in den Wireframe-Mode (taste Z). Nun wähle alle Polygone an, die falsch herum sind. Dabei empfiehlt sich ein andauerndes Wechseln zwischen dem Wireframe- und dem Solid-Mode. Das geht in beide Richtungen auch mit Z. Wenn du alle die Polygone ausgewählt hast, drücke W --> Flip Normals. Nun wurden die ausgewählten Polygone gedreht, aber ohne irgendwas an dem Mapping verändert zu haben.

    Bei weiteren Fragen melde dich gerne. :-)


    Gruß