Transparenz bei Kreuzungsmarkierungen

Welcome to the OMSI-WebDisk!
As guest you can only see content in your selected language! Registered users can choose the visibility of other languages in their control panel, more informations here. All topics are marked with a language flag inside the forums: = English [EN], = German [DE], = French [FR].
If you're not able to speak the topic language than write in English!
  • Guten Abend,

    nach dem Bau einer Kreuzung in Blender habe ich noch schnell die Fahrbahnmarkierungen hinzugefügt. Wie so manche, sind diese etwas älter. Demzufolge brauche ich auf der Textur eine Transparenz. So gab ich diese in der .sco an (mit [matl_alpha]), jedoch bekam ich ein Error, dass in Zeile 22 (Ort des [matl_alpha]) ein Fehler sei.


    Nun, bislang sehen die Markierungen so aus:

    OMSI erkennt also keine transparenz - wie auch.

    Weiß jemand, wie man dort die Markierungen transparenz machen kann?


    Danke schonmal.


    Grüße

    Bamp

  • Advertisement
  • wie hast du die Markierungen denn genau da drauf gemacht? Mit dem Kreuzungseditor entsprechende Splines reingemacht, oder direkt in Blender (wohl eher weniger.

  • Ich habe leider keine Glaskugel, die in deine .sco-Dateien hereinschauen kann. :) Würdest du uns die Datei mal anhängen? - und am Besten gleich auch die Logfile.

    PS: Das schwarze am Rand der Markierungen deutet daraufhin, dass die Transparenz nicht geladen wird.

    wie hast du die Markierungen denn genau da drauf gemacht? Mit dem Kreuzungseditor entsprechende Splines reingemacht, oder direkt in Blender (wohl eher weniger.

    Erstens kann man mit dem Kreuzungseditor keine Splines, sondern nur Pfade legen, zweitens handelt es sich um eine .sco-Datei dementsprechend ist anzunehmen, dass Bamp die Markierungen in Blender verlegt hat.

  • wie hast du die Markierungen denn genau da drauf gemacht? Mit dem Kreuzungseditor entsprechende Splines reingemacht, oder direkt in Blender (wohl eher weniger.

    Nein, habe ich in Blender gemacht.

    PS: Das schwarze am Rand der Markierungen deutet daraufhin, dass die Transparenz nicht geladen wird.

    Die sind so schwarz, weil ich den [matl_alpha]-Eintrag rausgenommen habe. Sonst wurde die Kreuzung gar nicht angezeigt.

    Nachher hänge ich Mal Logfile und .sco, einmal mit und ohne [matl_alpha], an.

    • Helpful

    Kenne es aus den model.cfg's bei Bussen so, dass das [matl_alpha] unter dem [mesh]-Eintrag angegeben werden muss, denke mal, dass es bei einem Kreuzungsobjekt ähnlich ist.


    Würde dann so aussehen:



    Das [matl_alpha] im oberen Teil der .sco kann dann hiermit auch weg.


    Hoffe, dass das hilft.

  • Ja, das hat geholfen, danke^^


    Ich weiß nicht, das wäre auch so logisch gewesen:D

  • Genau so ist es. Hintergrund ist folgender: Es können mehrere Mesh-Einträge pro sco-Datei definiert werden (bpsw. Scheiben/Glas getrennt vom Hauptmesh) mit unterschiedlichen Texturen. Ein [matl]-Eintrag bezieht sich immer nur auf genau ein Mesh.