Extrem lange Ladezeiten nach Einfügen eines Bildes

Welcome to the OMSI-WebDisk!
As guest you can only see content in your selected language! Registered users can choose the visibility of other languages in their control panel, more informations here. All topics are marked with a language flag inside the forums: = English [EN], = German [DE], = French [FR].
If you're not able to speak the topic language than write in English!
  • Moin,

    in letzer Zeit habe ich beim Bilder-Upload in der Webdisk festgestellt, dass nach diesem alles extrem hängt. Da man es schlecht erklären kann, habe ich das ganze kurz aufgezeichnet.



    Man sieht schon wie es beim Schreiben des Textes hängt.


    Vor längerer Zeit hatte ich schon mal das selbe Problem. Dort habe ich (versucht), in den Quellcode zu schauen, was mir nach relativ langer ZEit auch geling. Dort waren dann abnormal viele Zeichen. Es scheint also so, als wenn dort das Bild "vollständig" eingebettet wurde. Der ganze Quellcode ist 7 MB groß. Den habe ich mal in den Anhang gehangen.



    Grüße

  • Advertisement
  • Ich weiß gerade nicht genau, wie es ist, wenn man das über den Hochladen-Button macht, aber ist dann ja wohl das selbe Problem.

  • Hallo


    Wieso bindest Du das Bild nicht als Komprimierte Vorschau ein ?


    So masche ich das auch und habe dann auch keine Ruckler, und man kann dann beim Bilder anschauen einfach auf das Bild klicken und sieht es in voller Grösse.

    Gruss Daniel


    Aus dem schönen Wolhusen ( Rottal ) Schweiz


    forum.png

  • Hallo


    Wieso bindest Du das Bild nicht als Komprimierte Vorschau ein ?


    So masche ich das auch und habe dann auch keine Ruckler, und man kann dann beim Bilder anschauen einfach auf das Bild klicken und sieht es in voller Grösse.

    Selbst wenn es funktioniert, dann wäre es immer noch ein Work Around und nicht die Lösung des Problems

  • Wieso bindest Du das Bild nicht als Komprimierte Vorschau ein ?

    Es geht in den Screenshotthreads ja um ... hm, die Screenshots eben. Wenn man dann da so durchscrollt, willst du dann jedes Bild erst anklicken, damit du es in voller Größe hast?

  • Ja es geht um den Screenshots Thread !

    Voher war es ja noch schlimmer da musste man xxxx Links anklicken um vielleicht dann ein Bild zu sehen was man auch sehen wollte.

    Wo liegt das Problem, ein Bild an zu klicken, das es Gross angezeigt wird, lieber so als wie damals noch xxxx Links an zu klicken.


    Und Wörki hat ja dazu auch mal was geschrieben, wenn jeder auf einer Gasnzen Seite, seine Bilder nur in der Original Grösse reinstellt, verbraucht das wieder Unmengen an MB's die geladen werden müssen.

    Wörki hat sogar geschrieben am besten wäre es eben die Bilder als Vorschau rein zu packen, da dann die Seite trotzdem schneller lädt und weniger Mb's beraucht werden.

    Und trotzdem kann man dann immer noch die Bilder anklicken und sie in voller Grösse sehen.


    Weil Wörki auch geschrieben hat, das Sie nicht unlimitierten Gb verbrauch haben, aber einer gewissen Gb Zahl, müssen die überschüssigen Gb's extra bezahlt werden.


    Und dann findest DU Bamp es schlimm, wenn man mal ein paar Bilder anklicken muss ?

    Gruss Daniel


    Aus dem schönen Wolhusen ( Rottal ) Schweiz


    forum.png

  • Und dann findest DU Bamp es schlimm, wenn man mal ein paar Bilder anklicken muss ?

    Dein Lösungsvorschlag ist nunmal nicht seiner. Ich kann mich mit Firefox 80.0a1 nicht über solche Problematiken beschweren, weil sie bei mir einfach nicht auftreten.

  • Und dann findest DU Bamp es schlimm, wenn man mal ein paar Bilder anklicken muss ?

    =

    [..] dann wäre es immer noch ein Work Around und nicht die Lösung des Problems

    Hast du dir das Video oben angeschaut? Da siehst du, es hängt auch schon, als nur die Vorschau drinne war.


    Und Wörki hat ja dazu auch mal was geschrieben, wenn jeder auf einer Gasnzen Seite, seine Bilder nur in der Original Grösse reinstellt, verbraucht das wieder Unmengen an MB's die geladen werden müssen.

    Jetzt werden doch alle Bilder komprimiert. Dann sind die nicht unbedingt mehr als 150 KB groß.



    Und dann findest DU Bamp es schlimm, wenn man mal ein paar Bilder anklicken muss ?

    Das ist ja ein strenges Klima hier. Reg dich mal ein bisschen ab.

  • Hast du das mal schon mal ohne STRG+V probiert? Also wirklich einfach nur auf den Button Hochladen gehen und die Datei auswählen?

    Ich kann das nämlich nicht reproduzieren und ich nutze Chrome.


    Und Wörki hat ja dazu auch mal was geschrieben, wenn jeder auf einer Gasnzen Seite, seine Bilder nur in der Original Grösse reinstellt, verbraucht das wieder Unmengen an MB's die geladen werden müssen.

    Wir haben ja auch bereits die Anzahl der Posts pro Seite von 20 auf 10 herabgesetzt. War das überhaupt jemandem aufgefallen? ;)


    Und dann findest DU Bamp es schlimm, wenn man mal ein paar Bilder anklicken muss ?

    Ja, ICH Schleswig-Holstein, finde das auch schlimm. Ich gucke durch den Screenshot-Thread sehr gerne wie durch eine Galerie. Einfach schöne Posts mit schönen Bildern angucken. Weshalb meine Beiträge zb immer zentriert, etc sind. Dies wird durch die Vorschau natürlich zerstört.

    Das ist halt Geschmackssache.

  • Hallo


    Ja natürlich ist es angenehmer einfach durch die Seite runter zu Scrollen , und alle Bilder sind in Gross dar gestellt.

    Ich schaue die ScreenShots Thread die es so gibt, auch lieber so an das alle Bilder Gross angezeigt werden, da kann man einfach schön nach unten srollen und es anscheuen wie in einer Galerie.


    Ich wollte auch niemanden angreifen, wegen dem ob man jetzt auf ein Bild klicken muss oder nicht. Sollte das falsch das jemand falsch verstanden haben, dann entschuldige ich mich dafür.

    Denn angreifen will ich sicher niemanden.


    Hast Du dem Tatra oder dem Wörki schon eine PN wegen dem Problem gesendet, denn die können ja eigentlich nur sagen ist da ein Fehler drin oder ist das einfach so.

    Gruss Daniel


    Aus dem schönen Wolhusen ( Rottal ) Schweiz


    forum.png

  • Hast Du dem Tatra oder dem Wörki schon eine PN wegen dem Problem gesendet, denn die können ja eigentlich nur sagen ist da ein Fehler drin oder ist das einfach so.

    Das werden die beiden auch hier sehen ;)

  • Ich kann eure Fehler leider nicht nachvollziehen. Habt ihr es mal mit einem anderen Browser probiert?


    Ich konnte soeben unter Firefox sowohl per STRG+V aus der Zwischenablage als auch per Copy&Paste (das Gleiche wie der Hochladen-Button) ein 12MB-JPG und ein 25MB-PNG hochladen und (auf 154KB bzw. 5MB komprimiert) ohne Freeze des Editors in Originalgröße einbinden. Lediglich beim PNG mit STRG+V gab es einen Freeze, aber während des Hochladens.

  • Ich habe den Fehler auch nicht. Früher gab es mal kleine Hänger in der Admin-Ebene, wenn ich dort reingeschaut habe. Aber beim Bilder- oder Dateiupload habe ich es nie gesehen und kann es dementsprechend nicht reproduzieren oder den Fehler nachvollziehen.

  • Bamp  DerGrafikfehler Der Fehler sollte nun erledigt sein:

    Bei der Verarbeitung bestimmter Bildarten konnte es beim Upload zu einer Endlosschleife im Browser kommen.

    Könntet Ihr noch einmal Rückmeldung geben, ob sich das erledigt hat?

  • Moderator

    Added the Label Fixed