[Gelöst] Bestmögliche Performance auf Hamburg erreichen

Welcome to the OMSI-WebDisk!
As guest you can only see content in your selected language! Registered users can choose the visibility of other languages in their control panel, more informations here. All topics are marked with a language flag inside the forums: = English [EN], = German [DE], = French [FR].
If you're not able to speak the topic language than write in English!
  • Hallo WebDisk-Besatzung!


    Wie der Titel schon sagt: Ich bin seit Tagen schon wieder am Rumfummeln an der Hamburg-Map. Ich habe einfach heftigste Probleme mit der Performance. Meine Erkenntnisse zum Thema FPS-Rate sind überdies hochgradig seltsam... Ich habe beispielsweise am Rathausmarkt 60 FPS, fahre ich los, wird es sehr häufig konsequent schlechter - teilweise komme ich dann mit 8 FPS Alsterdorf an.


    Einstellungen wie folgt:


    System:

    CPU: Intel® Core™ i7-4770 Prozessor

    Betriebssystem (OEM Version): Windows 8.1

    Taktfrequenz: 3,4GHz

    Arbeitsspeicher Kapazität: 16GB

    Arbeitsspeicher Typ: DDR3 1600 MHz

    Festplattenkapazität: 2.000GB

    SSD Kapazität: 512GB

    Grafik: NVIDIA® GeForce® GTX1080 Ti DirectX®12 Grafik mit 11264 MB GDDR5X Speicher


    Was ich bisher versucht habe:

    • 4GB-Patch
    • mitgelieferte, performanceschonende Ai-List (nur 2017er C2)
    • HD-Festplatte defragmentiert
    • Grafikkarte in ihren Einstellungen optimiert
    • Spiegelreflexionen an den Bussen angepasst


    Ehrlich gesagt bin ich mit meinem Latein am Ende... Hamburg ist ein echt harter Brocken... Nicht einmal Spandau hat solche Probleme gemacht...

    "Selten ein Schaden, wo nicht auch ein Nutzen ist."

  • Advertisement
  • Ich würde erstmal die max. Anzahl Busse noch weiter heruntersetzten. Wirklich auf 20 oder so. Das habe ich auch, da die Busse von Darius leider sehr performacefressend sind.


    Ansonsten die Anzahl Nachbarkacheln testweise mal auf 1.

  • Moin B&B,


    Dass du trotz Fahrplanpriorität auf 1, d.h. keine Fähren oder Züge, so massive Differenzen hast, wundert mich.

    Generell bei 2 Nachbarkacheln; ca. 25-35 FPS, Hauptbahnhof 20, Randbereich 35 FPS.

    Ich füge mal meine Optionen bei:


    - -


    Besonders hervorheben möchte ich die Option der dynamischen Kachelreduktion bei geringer Performance. Die hast du aber sinnvoll eingestellt.

    Der Umgebungsverkehr ist fast maximal bei mir.


    Ist´s auf anderen Karten auch so arg, dass du die Kartenkomplexität reduzieren musstest?


    Mein System:

    Processor
    AMD Ryzen 5 1600X Six-Core Processor

    Video Card
    NVIDIA GeForce GTX 1050 Ti

    RAM
    16 GB

    SSD, Windows 10

  • Ich weiß nicht... Ich halte Darius' Busse generell für schwierig. Aber wenn das bei dir so gut läuft, dann können die Busse ja generell kein großartiges Problem sein.

    "Selten ein Schaden, wo nicht auch ein Nutzen ist."

  • Ich weiß nicht... Ich halte Darius' Busse generell für schwierig. Aber wenn das bei dir so gut läuft, dann können die Busse ja generell kein großartiges Problem sein.

    Das ist ein bisschen Stochern im Dunkeln, weil im Prinzip ja die Karte Hamburg keine "Besonderheiten" zu anderen Karten mit komplexer Bauweise aufweist, die Performance beeinflussen könnten. Ich nehme an, die Logfile ist auch nicht mit Errors vollgeschossen? Beschädigte Busse wirken sich teils stark aus.

  • Ich glaube ja, dass die 2 Nachbarkacheln zu viel Performance ziehen.

    Bei Nachbarkacheln...

    0 (ich weiß, geht nicht) = 1 Kachel geladen

    1 = 9 Kacheln geladen

    2 = 25 Kacheln geladen.


    Ich persönlich nutze deswegen nur 1 Nachbarkachel. Zudem würde ich die Partikel ausmachen, bei mir zieht das auch heftig Performance.

  • Das ist ein bisschen Stochern im Dunkeln, weil im Prinzip ja die Karte Hamburg keine "Besonderheiten" zu anderen Karten mit komplexer Bauweise aufweist, die Performance beeinflussen könnten. Ich nehme an, die Logfile ist auch nicht mit Errors vollgeschossen? Beschädigte Busse wirken sich teils stark aus.

    Ich habe schon überlegt, ob ich OMSI einfach via STEAM reparieren lassen sollte...


    Abgesehen von irgendwelchen fehlenden Texturen sagt die Logfile nicht viel... Ich bin ehrlich gesagt ratlos. Durchweg 30 FPS wäre ja völlig in Ordnung. Aber diese heftige Streuung von ~50 FPS an kuriosen Stellen macht mich völlig ratlos...

    "Selten ein Schaden, wo nicht auch ein Nutzen ist."

  • Ich würde auch die Partikel und die Nachbarkacheln nochmal ändern. Ebenso die Zielwiederholrate noch ein wenig herunterdrehen, aber das ist Geschmackssache.
    Hast du ansonsten schon mal das Video von iajer dir angeguckt? Nur so ein Tipp.


    Aber ja ich muss zugeben, dass das auch recht komisch alles wirkt...

  • Ebenso die Zielwiederholrate noch ein wenig herunterdrehen, aber das ist Geschmackssache.

    Die kann ja auf 60 Frames, mehr sieht man ja auch nicht besonders.


    Wie viel GB hat dein Hauptverzeichnis denn?

  • Wie sieht's mit den Sounds aus? Testweise könntest du mal die Umgebungsgeräusche und alles Andere aus stellen

  • Erfahrungsgemäß kann man an KI-Bussen sehr viel schrauben, scheint bei dir aber nicht das Problem zu sein. Scheinbar hast du ja am RAM ne bessere Performance als in UAL, obwohl am RAM viel mehr KI-Verkehrs sein sollte...


    Wie ist es denn wenn du von UAL in die Stadt fährst? Hast du dann auch in UAL ne Bessere Performance oder kommen die Performanceeinbrüche mit zunehmender Spielzeit?

    Aktuell: Projekt Dreiländereck: Map & Repaints aus dem Großraum Basel


  • [...]


    Wie ist es denn wenn du von UAL in die Stadt fährst? Hast du dann auch in UAL ne Bessere Performance oder kommen die Performanceeinbrüche mit zunehmender Spielzeit?

    Kommt drauf an... Entweder, ich habe gleich nach Spielstart 12 FPS oder ich starte mit 60 am Rathausmarkt und komme in Alsterdorf mit 6 an... Andere Richtung muss das nicht besser oder schlimmer werden... Alles sehr sporadisch...

    "Selten ein Schaden, wo nicht auch ein Nutzen ist."

  • Ich habe auch nur meist 20 FPS aber am Hauptbahnhof gehen machmal bis 7 runter. Gehen dann aber auch nicht mehr hoch auf 20 sondern immer nur auf 13.


    Prozessor: AMD Athlon X2 270 3,4 Ghz 8(2 Kerne)

    Ram: Elixir 8GB DDR3 1600 Mhz

    Grafikkarte: nVidia geforce 8400 GS

    OMSI ist auf einer 160GB HDD installiert.

  • Lµkas: Jaja... Das Video kenne ich ausführlich... Hilft alles nicht.


    Mein Hauptverzeichnis ist heftig... Dürfte so um die 60 GB haben... 8o8o

    ich glaube du meinst Schleswig-Holstein? ^^

  • Ich persönlich nutze deswegen nur 1 Nachbarkachel.

    Ich auch, würde ich auc (zumindest Testweise) empfehlen.


    Zudem würde ich die Partikel ausmachen, bei mir zieht das auch heftig Performance.

    Okay, die ziegen bei mir keinen einzigen Frame ...:/

  • Dafür gibts ja eigentlich die Dynamische Kachelreduktion. In Außenbereichen (z.B: UAL) kommt OMSI bei mir gut mir 2 Nachbarkacheln klar, in Richtung Innenstadt dann wird die Anzahl der Nachbarkacheln mit sinkender FPS automatisch gesenkt.


    Berlin&Brandenburg

    Und den Speicherbedarf für Hochauflösende Texturen kannst ruhig hochstellen, ich vermute mal bei einer GraKa mit über 10GB bringen Low-Res-Texturen keine Performanceverbesserung.


    Ich hatte manchmal so Performanceabstürze teilweise auch schon, wenn sich Zugriffsverletzungen oder Bereichsprüfungsfehler einschleichen - hast du mal in die Logfile geschaut?

    Aktuell: Projekt Dreiländereck: Map & Repaints aus dem Großraum Basel